User Tools

Site Tools


apache2_php_.la_is_not_a_dso_file

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

apache2_php_.la_is_not_a_dso_file [2009/04/22 13:23] (current)
k2patel created
Line 1: Line 1:
 +====== DSO Issue ======
  
 +This is a issuse with apache when you try to install any module to it it gives error.
 +
 +e.g. If you are running the php install as module
 +
 +<code bash>
 +./configure ----- OK
 +make ------ OK
 +But,
 +make install ---- Failed with message .la is not a dso file
 +
 +./libtool --mode=install cp libphp5.la /​usr/​lib/​apache/​modules/​
 +./libtool --finish
 +
 +Now, you might need the non apache version of application.
 +
 +in that case you need to get rid of APXS2 variable from configure.
 +</​code>​
apache2_php_.la_is_not_a_dso_file.txt ยท Last modified: 2009/04/22 13:23 by k2patel