User Tools

Site Tools


zfs

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

zfs [2016/05/09 19:10]
k2patel [Nexenta]
zfs [2020/08/10 02:35]
Line 1: Line 1:
-====== ZFS ====== 
  
-==== Zpool ==== 
- 
- 
-To check zpool status 
-<code bash> 
-zpool status [<​volume>​] 
-</​code>​ 
-To clear error on drive, which you think reported wrongly. 
-<code bash> 
-zpool clear <volume name> 
-</​code>​ 
-To add Zeus Drive 
-<code bash> 
-zpool add performance log <​drive>​ 
-</​code>​ 
-Adding spare to volume 
-<code bash> 
-zpool add performance spare <​drive>​ 
-</​code>​ 
-Remove attached spare drive to volume 
-<code bash> 
-zpool detach <​volume>​ <​Drive>​ 
-</​code>​ 
-Removing drives from volume (require to remove spare drives after raid rebuilt) 
-<code bash> 
-zpool remove <​Volume>​ <​Drive>​ 
-</​code>​ 
- 
-==== Nexenta ==== 
-=== Disk / Lun === 
-To blink drive use following command in NMC 
-<code bash> 
-show lun c8t5000C5005785138Bd0 blink -y 
-</​code>​ 
- 
-==== Solaris ==== 
- 
-List all faults on system 
-<code bash> 
-fmadm faulty 
-</​code>​ 
-Clearing Faults 
-<code bash> 
-fmadm repair <​faulty_id>​ 
-</​code>​ 
-Checking Service status 
-<code bash> 
-svcs nm{s,v,cd} dbus rmvolmgr nmdtrace 
-</​code>​ 
-Restarting Services 
-<code bash> 
-svcadm restart nms 
-</​code>​ 
-Loading unloading zfs-diagnosis module 
-<code bash> 
-fmadm load /​usr/​lib/​fm/​fmd/​plugins/​zfs-diagnosis.so 
-</​code>​ 
-Clearning dangling dev link 
-<code bash> 
-devfsadm -Cv 
-</​code>​ 
zfs.txt ยท Last modified: 2020/08/10 02:35 (external edit)